Digital design and other shiny toys

Install software, bang head on keyboard

Posted on by Paul

This is a tech related post for anyone installing the new Adobe CS5 applications on a Mac. If you don’t work in design or related industries this will be really dull. Sorry. I’ll try to post something interesting next time to make up for it.

Anyway, I installed my Adobe CS5 Design Premium upgrade today and was all set to try some noodling in Photoshop. (‘Noodling’ is a technical term – it’s what I do instead of working.) Photoshop started but it wouldn’t save my settings, instead complaining about a locked file. I could see where this was going so I tried the other applications in the CS5 collection. They wouldn’t even start up, which isn’t great when you have some logo design to do in Illustrator. A few minutes searching online and I discovered lots of people were having the same problem.

It seems the CS5 installer sometimes forgets to add the active user to the account permissions for the files it creates. When the user launches one of the applications all sorts of things go wrong because preference folders can’t be created/accessed, files updated etc. etc. I imagine there will be a fix from Adobe in the next few days but I was able to get things working reasonably well by reading through posts on the support forum.

I updated the sharing and permissions info for the following items, adding myself as the owner with full access. (You can then apply this permission to all items within a folder, which saves time.)

In the Applications folder:

  • Adobe Bridge CS5
  • Adobe Device Central CS5
  • Adobe Dreamweaver CS5
  • Adobe Extension Manager CS5
  • Adobe Illustrator CS5
  • Adobe Photoshop CS5

In the ~user/Library/Preferences folder:

  • Adobe
  • Adobe Photoshop CS5 Settings

In the ~user/Library/Application Support Folder:

  • Adobe

This is the brute force approach and probably not the best way, but it worked for me. I offer no guarantees. Use at your own risk and be prepared to re-install the whole lot when the official fix is released.

Adobe have form with this kind of thing, having mucked up file permissions with older versions of the Flash plug-in installer. I also remember issues with InDesign when I worked in repro. Mind you, as irritated as I was this morning, I imagine the Adobe tech support staff are having a really bad day. Be nice to them if you call.

UPDATE: Looks like the Adobe support staff are getting annoyed now. I’ve also discovered that the CS5 applications are extremely fussy about fonts. I wasn’t able to use the type tools until I disabled some fonts that had never caused problems before. Another solution to the problem described is to create a new admin-level account and re-install the whole CS5 package from there. Then delete the new account, log-in to your normal one, remove any CS5 applications settings and try again. By that time any creative urges you had will be long gone and you’ll need a break, but it seems to work.

Comments are closed.

Read the comments policy